Total members 11892 |It is currently Thu Sep 19, 2024 5:31 pm Login / Join Codemiles

Java

C/C++

PHP

C#

HTML

CSS

ASP

Javascript

JQuery

AJAX

XSD

Python

Matlab

R Scripts

Weka





You have a necklace of N red, white, or blue beads (3<=N<=350) some of which are red, others blue, and others white, arranged at random. Here are two examples for n=29:

1 2 1 2
r b b r b r r b
r b b b
r r b r
r r @ r
b r @ @
b b r r
b b b b
b b r b
r r b r
b r r r
b r r r
r r r b
r b r r r @
Figure A Figure B
r red bead
b blue bead
@ white bead

The beads considered first and second in the text that follows have been marked in the picture.

The configuration in Figure A may be represented as a string of b's and r's, where b represents a blue bead and r represents a red one, as follows: brbrrrbbbrrrrrbrrbbrbbbbrrrrb .

Suppose you are to break the necklace at some point, lay it out straight, and then collect beads of the same color from one end until you reach a bead of a different color, and do the same for the other end (which might not be of the same color as the beads collected before this).

Determine the point where the necklace should be broken so that the most number of beads can be collected.
Example

For example, for the necklace in Figure A, 8 beads can be collected, with the breaking point either between bead 9 and bead 10 or else between bead 24 and bead 25.

In some necklaces, white beads had been included as shown in Figure B above. When collecting beads, a white bead that is encountered may be treated as either red or blue and then painted with the desired color. The string that represents this configuration will include the three symbols r, b and w.

Write a program to determine the largest number of beads that can be collected from a supplied necklace.
PROGRAM NAME: beads
INPUT FORMAT
Line 1: N, the number of beads
Line 2: a string of N characters, each of which is r, b, or w
SAMPLE INPUT (file beads.in)

29
wwwbbrwrbrbrrbrbrwrwwrbwrwrrb

OUTPUT FORMAT
A single line containing the maximum of number of beads that can be collected from the supplied necklace.
SAMPLE OUTPUT (file beads.out)

11


The solution :
Code:
/*

PROG: beads
*/

/* Recursive solution which exploits the
pattern in the problem statement. Be careful
with the white beads. */

#include <iostream>
#include <fstream>
#include <string>
#include <iomanip>
#include <vector>
#include <math.h>
using namespace std;

int bcount(string neck,int st)
{
  int cnt=1;
  int cur=st; int oldcur=st;

  int cta=0;
  do {
    oldcur=cur;
    cur=(cur+1)%neck.size();   
    if (cur==st) break;
    if (neck[cur]=='w') neck[cur]=neck[oldcur];   
    if (!(neck[oldcur]=='w') && (neck[cur]!=neck[oldcur])) break;
    cnt++;
    cta++;
  } while (1);

  int ct=0;
  for (int k=st; ct<=cta; ct++, k=(k+1)%neck.size())
    neck[k]='.';

  cur=(st-1+neck.size())%neck.size(); oldcur=cur;
  if (neck[cur]!='.') cnt++;
  do {
    oldcur=cur;
    cur=(cur+neck.size()-1)%neck.size();   
    if (neck[cur]=='w') neck[cur]=neck[oldcur];   
    if (((neck[oldcur]!='w') && (neck[cur]!=neck[oldcur])) || (neck[cur]=='.')) break;
    cnt++;
  } while (cur!=st);
  return cnt;
}

void main()
{
  fstream fin,fout;
  int i;
  fin.open("beads.in",ios::in);
  cin=fin;
  fout.open("beads.out",ios::out); 
 
  int no;
  string nck;
  cin >> no >> nck;
  int max=0;
  for (int k=0; k<no; k++)
    if (bcount(nck,k)>max) max=bcount(nck,k);

  fout << max << endl;
  fout.close();   
}




_________________
M. S. Rakha, Ph.D.
Queen's University
Canada


Author:
Mastermind
User avatar Posts: 2715
Have thanks: 74 time
Post new topic Reply to topic  [ 1 post ] 










Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
All copyrights reserved to codemiles.com 2007-2011
mileX v1.0 designed by codemiles team
Codemiles.com is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to Amazon.com